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Objective – 

 
This tutorial provides comprehensive information that will help you understand how 
to create a FPGA design and run it on your DE10-Lite development board. The 
following sections provide a quick overview of the design flow, explain what you need 
to get started, and describe what you will learn.  
 
The standard FPGA design flow starts with design entry using schematics or a 
hardware description language (HDL), such as Verilog HDL or VHDL. In this step, you 
can create a digital circuit that is implemented inside the FPGA. The flow then 
proceeds through compilation, simulation, programming, and verification in the 
FPGA hardware. 

This tutorial will not make you an expert, but at the end, you will understand basic 

concepts about Quartus Lite projects, entering design using HDL, compiling your 

design, and downloading it into the FPGA on your DE10-Lite development board. 

Terasic DE10-Lite is a cost-effective Altera MAX 10 based FPGA board. The board 

utilizes the maximum capacity MAX 10 FPGA, which has around 50K logic 

elements(LEs) and on-die analog-to-digital converter (ADC). It features on-board 

USB-Blaster, SDRAM, accelerometer, VGA output, 2x20 GPIO expansion connector, 

and an Arduino UNO R3 expansion connector in a compact size. The kit provides the 

perfect system-level prototyping solution for industrial, automotive, consumer, and 

many other market applications. 

 

Index - 

• Section 1 – Download and install Altera Quartus Lite Software on Windows/Linux  

• Section 2 – Setup a new project in Quartus Lite Software 

• Section 3 – Implement a function using Verilog HDL 

• Section 4 - Simulate the Verilog circuit using ModelSim + Verilog test bench  

• Section 5 – Pin assignment and Constraint generation 

• Section 6 - Synthesize, Implement, Generate, and Program DE10-Lite  board  
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Board Overview – 

o Go over the chapters 1 and 2 in DE10-user manual to understand the board 

components and the control panel setup. 
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Section 1 - Download and install Altera Quartus Lite 

Software 

1. Browse to the hyperlink provided below and make sure that Lite edition and 18.1 

release are selected. Also, check the appropriate OS box(Windows/Linux). Use any 

download method (Direct Download works faster) and make sure to download only 

the individual files marked in the next bullet. Create a basic account on Intel using 

UnID if prompted -> http://fpgasoftware.intel.com/18.1/quartus_lite  

 

 
 

2. Navigate to the Individual files tab and download the Quartus prime lite edition, 

ModelSim FPGA edition, along with MAX 10 FPGA device support. 

 

 

http://fpgasoftware.intel.com/18.1/?edition=lite&platform=windows&download_manager=direct


DIGITAL SYSTEM DESIGN 
 

3. Select the QuartusLite setup file and Run as administrator for windows 

installation. For Linux, modify the *.run file with executable 

permissions(chmod +x *.run) and execute the *.run  on terminal as super 

user(sudo \.*.run). 

 
 

4. Press Yes and click Next in the QuartusLite setup installation prompt. Accept 

the agreement and click Next again. Select the appropriate installation folder 

or retain the default directory. Make sure the following boxes are 

marked(modelsim and MAX 10 device support) for installation. And Press Next 

and let the installation complete 

 
 

5. The setup should also install ModelSim FPGA edition along with QuartusLite 

Software(If not, you can install it separately). After the installation, the setup 

will prompt for installation of USB Blaster 2 device driver which is required for 

FPGA programming. Click Next and finish the installation. 
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Section 2- Setup a new project in Quartus Lite Software 

You begin this section by creating a new Quartus  project. A project is a set of files that 

maintain information about your FPGA design. The Quartus  Settings File (.qsf) and 

Quartus  Project File (.qpf) files are the primary files in a Quartus  project. To compile 

a design or make pin assignments, you must first create a project. 

1. Launch the Quartus  software, select File > New Project Wizard. The Introduction 

page opens 

 

2. Enter the following information about your project as shown in the next snapshot:   
a. What is the working directory for this project? Enter a directory in which 

you will store your Quartus  project files for this design.  
b. For example, C:\intelFPGA_lite\18.1\quartus\3700_lab\  
c. File names, project names, and directories in the Quartus  software cannot 

contain spaces.  
d. What is the name of this project? Type hexTo7Seg.  
e. What is the name of the top-level design entity for this project? Type 

hexTo7Seg. 

f. Create a directory if it isn’t present. 
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3. Select the Empty project template and click Next:  
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4. Click Next twice and navigate to the Family, Device and Board Settings.  Select the 
specifics on the respective device target as mentioned below (Device – 

10M50DAF484C7G). You can add the required Verilog files later or edit the files in 
the Quartus editor once the project has been setup.  

 

5. Select the simulation Tool as ModelSim-Altera(note – this is not just ModelSim 

but the one with Altera) and format as Verilog HDL. Retain the other Tool 

selections to default. 
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6. Review the new project summary page and make sure all the specifics that you 

entered are reflected. 

 

 

7. Quartus Lite Project navigator will now reflect the instance as your top level 

design entity under the device name. 
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Section 3 – Implement a function using Verilog HDL 

1. Once you have created and setup your project, the next step is to describe your 

design using a hardware description language.  

Go to File-->New→Select Verilog HDL File. 

 

2. Once a new file is created, you will be able to enter your code into it. When you 

save it, you have to have the module name and file name match up. Remember 

that one of the file names must match the name of the project. Double check 

and make sure that the Save as type is Verilog HDL Files. 
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3. Every project in hardware needs a testbench to generate all necessary inputs 

and read outputs to ensure they are correct. This is very similar to writing test 

cases in software programming. The standard practice of naming a testbench is 

to add a "tb_" in front of the name of the module you are testing. In this case, 

we are testing hex to seven segment display, so the name of the new Verilog 

HDL file is saved as "tb_hexTo7Seg". A testbench is just another standard 

Verilog HDL File. 

 

4. If you already have a file present in your directory, you can add/remove files to 

the project by navigating to “project->add/remove files in project”. Select the 

files -> apply -> ok. 
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Section 4 - Simulate the Verilog circuit using ModelSim + 

Verilog test bench  

1. To setup the simulation Tool path for ModelSim-Altera, navigate to 

Assignments→ Settings and modify the simulation parameters as shown below. 

 

2. Under EDA Tool settings, check on Simulation option and it should show the 

Tool name as ModelSim-Altera. 
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3. Output directory can be e.g. /simulation/modelsim. Then these new 
directories are created under the working directory, and the different 
Modelsim output files (.vo, .sdo) are placed here.  

4. Navigate to More EDA Netlist Writer settings and set the generate functional 

simulation netlist option to ON: click OK and Apply. 

 

5. You can automate the modelsim execution (compile/simulate) by setting up 
the testbench parameters in quartus software as follows. Enter the information 
about the testbench file under NativeLink settings. 

a. Select Compile test bench  
b. Click Test Benches. The Test Benches dialog box appears.  
c. Click New. The New Test Bench Settings dialog box appears.  

d. Enter the test bench details from your design – 
i. The Test bench name can be any suitable name by your choice. This name will 

later appear in the Compile test bench list.  
ii. The Top level module in test bench must be the name of the entity of your 

testbench file.  
e. You can also limit the simulation end time by entering a time limit in terms (us/ps/ms) 

in the “end simulation at” dialog box. 
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6. To setup the simulation executable path, click on Tools> Options> EDA Tool 

Options and and set the Modelsim-Altera path to your installation directory. 

 
 

7. After you have finished coding up your modules, double click on Analysis & 

Synthesis under the Tasks pane. If you do not see Analysis & Synthesis, double 

check that Flow is set to Compilation. This will compile and synthesize your 

program(s). If there are no errors, you will see a pop-up saying the Analysis & 

Compilation was successful. If not, it will tell you your errors in 

the messages pane at the bottom of the screen. It is good habit to just review 

your warnings (if any) to ensure you have no latches or other design hazards. 
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8. Once the Analysis & Synthesis is successful, you can do a RTL Simulation. Go 

to Tools-->Run Simulation Tool-->RTL Simulation. 

a. Now, if you have setup the testbench setup in nativelink settings as 

described before, the modelsim window will automatically 

compile/simulate the testbench mentioned there and will dump the 

port level signals from the top level module onto waveform. 

b. If you have not mentioned any testbench settings, you can follow the 

steps from next bullet to compile/simulate the design in Modelsim. 

 

 

 



DIGITAL SYSTEM DESIGN 
 

9. Go to Compile-->Compile. Ensure that the Library is work and navigate to your 

project directory. Select all Verilog HDL Files that pertain to your project. This 

includes the testbench. Hit Compile and then Done. 

 

10. If you look at the bottom in the Transcript pane, you will see that it did 

compile and there were no errors. The work library should have all the files you 

just compiled. If not, repeat the previous step. Since the testbench does the 

signal generations and testing, double click on your testbench file. 
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11. Click Simulate> Start simulation . Under work select the module to be 

simulated and click ok. 

 

12. The next step is to add signals to the wave and show the wave if it is not 

already present. On the left, in the sim pane, right click on the testbench file 

which should be the top most file. Go to Add->To Wave->All signals in region. 
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13. In the Wave pane, you will see all the signals declared and used in the 

testbench. 

 

Note - When dealing with signals that are many bits, it is easier to see its value as 

an unsigned integer/Hex rather than binary. To make this conversion, right click 

on the signal you want, go to Radix and choose the format you want.  

14. You are now ready to simulate your program. The icons boxed in the below 

screenshot are used to run the testbench. The first icon is Restart which will 

reset the simulation as if you never ran it. This is helpful to rerun the 

simulation without recompiling everything. The Run Length allows you to 

enter a specific amount of time you want the program to run for. It defaults to 

pico-seconds, but nano-seconds is the best time to use. The icon Run right 

after the Run Length is to run your program for the amount of time specified in 

the Run Length. If you set Run Length to be 10 ns, each time you press Run, the 

program will continue for 10 ns. Continue Run will run the program until it 

terminates. The same is true for Run -All. All the programs in this class will 

terminate in less than one second. If you find yourself waiting for longer than a 

few seconds until the program terminates, hit the Stop button and recheck 

your logic. you will see the following screen once your program terminates. It 

shows you where the program terminated. To go back to the Wave, click on 

the Wave tab. 
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15. Once you click Run, you should see something like this on your Wave with 

values propagated and reflected on all the intended signals in the wave. 

 

16. If you expand or scroll through the Transcript pane, you will see the output of 

any $display statements you have in your code. 
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Section 5 – Pin assignment and Constraint generation 

 

 

In this section, you will make pin assignments for all the signals from the design 

which interact with outer world. Before making pin assignments, perform the 

following steps:  

1. Choose Processing > Start > Start Analysis & Synthesis in preparation for 

assigning pin locations. Click OK in the message window that appears after 

analysis and elaboration completes. 
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2. To make pin assignments that correlate to the hex_input[3:0] input pins 

and seven_seg_out[6:0] output pins, perform the following steps:  Choose 

Assignments > Pin Planner, which opens the Pin Planner, a spreadsheet-like 

table of specific pin assignments. The Pin Planner shows the designs pins.  

 

 
 

3. In the Location column next to each of the node names, add the 

coordinates(pin numbers) as shown from the tables below for the actual 

values to use with your DE10-Lite board(check manual for any particular 
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pins you are looking for based on your design usage). Double-click in the 

Location column for any of the pins to open a drop-down list and type the 

pin number shown in the table. Alternatively, you can select the pin from a 

drop-down list. For example, if you type C12 and press the Enter key, the 

Quartus  software fills in the full PIN_C12 location name for you. The 

software also keeps track of corresponding FPGA data such as the I/O bank 

and VREF Group. Each bank has a distinct color, which corresponds to the 

top-view wire bond drawing in the upper right window. 

4. After filling pin numbers for all ports, close the pin planner window. 
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5. The <design>.qsf file should reflect these pin assignments once you have set 

them on pin planner.  
set_location_assignment PIN_C14 -to seven_seg_out[0] 

set_location_assignment PIN_E15 -to seven_seg_out[1] 

set_location_assignment PIN_C15 -to seven_seg_out[2] 

set_location_assignment PIN_C16 -to seven_seg_out[3] 

set_location_assignment PIN_E16 -to seven_seg_out[4] 

set_location_assignment PIN_D17 -to seven_seg_out[5] 

set_location_assignment PIN_C17 -to seven_seg_out[6] 

set_location_assignment PIN_C10 -to hex_input[0] 

set_location_assignment PIN_C11 -to hex_input[1] 

set_location_assignment PIN_D12 -to hex_input[2] 

set_location_assignment PIN_C12 -to hex_input[3] 

 

6. Timing settings are critically important for a successful design. For this 

tutorial you will create a basic Synopsys Design Constraints File (.sdc) that 

the Quartus  TimeQuest Timing Analyzer uses during design compilation. 

For more complex designs and requirements, you will need to create your 

.sdc files by considering the timing requirements more carefully.  

To create an SDC, perform the following steps:  

a. Open the TimeQuest Timing Analyzer by choosing Tools > TimeQuest Timing 

Analyzer.  

b. Choose File > New SDC file. The SDC editor opens in the quartus software with a 

file extension as .sdc.  

c. Type in your timing constraints(clock/pll) into the file and save it as top-level 

file(hexTo7Seg.sdc in this case). Since the current design doesn’t have a clock, we 

will ignore the constraints. Refer the DE10-Lite manual for creating a PLL/clock as 

it is explained in detail. 

d. Naming the SDC with the same name as the top-level file except for the .sdc 

extension causes the Quartus  software to using this timing analysis file 

automatically by default. If you used another name, you would need to add the 

SDC to the assignments file list. 
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Section 6 – Synthesize, Implement, Generate, and Program 

DE10-Lite  board 

After creating your design you must compile it to convert the design into a 

bitstream that can be downloaded into the FPGA. The most important output of 

compilation is an SRAM Object File (.sof), which you use to program the device. 

The software also generates other report files that provide information about your 

code as it compiles. If you want to store “*.SOF” in memory device (such as flash or 

EEPROMs), you must first convert the SOF to a file type specifically for the 

targeted device.  

Now that you have created a complete Quartus  project and entered all 

assignments, you can compile the design.  

1. In the task window – double click compile design or 

2. In the Processing menu, choose Start Compilation or  

3. click the Play button on the toolbar (cntrl+L).  

The Quartus  Messages window displays many messages during 

compilation. It should not display any critical warnings; it may display a few 

warnings that indicate that the device timing information is preliminary or that 

some parameters on the I/O pins used for the LEDs were not set. The software 

provides the compilation results in the Compilation Report tab as shown. 
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4. After compiling and verifying your design you are ready to program the 

FPGA on the development board. You download the SOF you just created 

into the FPGA using the USB-Blaster circuitry on the board. Set up your 

hardware for programming using the following steps:  

a. For the DE10-Lite board, connect the USB-Blaster (included in your 

development kit) to pin J3 and the other end of the USB cable to the 

host computer.  

5. Program the FPGA using the following steps.  

a. Choose Tools > Programmer. Once the Programmer window opens, 

click Hardware Setup. If it is not already turned on, turn on the 

DE10-Lite [USB-0] option under currently selected hardware. 

 

b. Make sure the Mode is set to JTAG. 

c. Click Auto Detect to detect all the devices on the JTAG chain. 

Select the device as 10M50DA which reflects the device ID for DE10-

Lite MAX-10 board. Click OK after the selection. 
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6. Select FPGA device and click Add File to program the FPGA with the 

relevant .sof file(hexTo7Seg.sof in this case). 

 

7. click Start to program the .sof file into FPGA and make sure the progress 

bar reflects success and not failure. 
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8. When you verify the design in hardware, observe the runtime behavior of 

the FPGA hardware and ensure that it is functioning appropriately. 

a. Play around with the switches (SW0-SW3) and see the 7-segment 

display varying .  

 

 

 “Congratulations, you have created, compiled, and programmed 

your first FPGA design! The compiled SRAM Object File (.sof) is 

loaded onto the FPGA on the development board and the design 

should be running.” 

 

References and miscellaneous links –  

• Altera Quartus Lite software: http://fpgasoftware.intel.com/18.1/quartus_lite  

• User manual/datasheets/demonstrations/control-panel/sample codes:  

o Click the link below (http://DE10-Lite.terasic.com/cd) and download the 

latest system build(DE10-Lite_v.2.0.3_SystemCD.zip) with Quartus 

16.0(>) support.  

• For enabling inbuilt Linux Subsytem in windows please follow the instructions 

mentioned in the article, it works like a charm: 

https://www.windowscentral.com/how-install-bash-shell-command-line-

windows-10  

 

http://fpgasoftware.intel.com/18.1/?edition=lite&platform=windows&download_manager=direct
http://de10-lite.terasic.com/cd
http://download.terasic.com/downloads/cd-rom/de10-lite/DE10-Lite_v.2.0.3_SystemCD.zip
https://www.windowscentral.com/how-install-bash-shell-command-line-windows-10
https://www.windowscentral.com/how-install-bash-shell-command-line-windows-10

